<!doctype html>
<html lang="en-US">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="profile" href="http://gmpg.org/xfn/11">

    <title>New ASWSUV Senators vote to begin impeachment process &#8211; The VanCougar</title>
        <style type="text/css">
        </style>
        <link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The VanCougar &raquo; Feed" href="http://thevancougar.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The VanCougar &raquo; Comments Feed" href="http://thevancougar.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The VanCougar &raquo; New ASWSUV Senators vote to begin impeachment process Comments Feed" href="http://thevancougar.com/2018/08/07/new-aswsuv-senators-vote-to-begin-impeachment-process/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.2.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.2.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-127212696-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-127212696-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/thevancougar.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://thevancougar.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='fts-feeds-css'  href='http://thevancougar.com/wp-content/plugins/feed-them-social/feeds/css/styles.css?ver=2.4.6' type='text/css' media='all' />
<link rel='stylesheet' id='post_grid_style-css'  href='http://thevancougar.com/wp-content/plugins/post-grid/assets/frontend/css/style-new.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='owl.carousel-css'  href='http://thevancougar.com/wp-content/plugins/post-grid/assets/frontend/css/owl.carousel.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://thevancougar.com/wp-content/plugins/post-grid/assets/frontend/css/font-awesome.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='style-woocommerce-css'  href='http://thevancougar.com/wp-content/plugins/post-grid/assets/frontend/css/style-woocommerce.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='style.skins-css'  href='http://thevancougar.com/wp-content/plugins/post-grid/assets/global/css/style.skins.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='style.layout-css'  href='http://thevancougar.com/wp-content/plugins/post-grid/assets/global/css/style.layout.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='sab-plugin-css'  href='http://thevancougar.com/wp-content/plugins/simple-author-box/assets/css/simple-author-box.min.css?ver=2.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='http://thevancougar.com/wp-content/themes/elegant-magazine/assets/bootstrap/css/bootstrap.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css'  href='http://thevancougar.com/wp-content/themes/elegant-magazine/assets/slick/css/slick.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='sidr-css'  href='http://thevancougar.com/wp-content/themes/elegant-magazine/assets/sidr/css/jquery.sidr.dark.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='chld_thm_cfg_parent-css'  href='http://thevancougar.com/wp-content/themes/elegant-magazine/style.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='elegant-magazine-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Oswald:300,400,700|Source%20Sans%20Pro:400,400i,700,700i&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='elegant-magazine-style-css'  href='http://thevancougar.com/wp-content/themes/elegant-magazine-child/style.css?ver=1.1.0.1528860961' type='text/css' media='all' />
<style id='elegant-magazine-style-inline-css' type='text/css'>


                .top-masthead {
        background: #353535;
        }
        .top-masthead-overlay{
        background: rgba(53,53,53,0.75);
        }
        
                .top-masthead, .top-masthead a {
        color: #ffffff;

        }

    

        
</style>
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='http://thevancougar.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://thevancougar.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.0' type='text/css' media='all' />
<script type='text/javascript' src='http://thevancougar.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ftsAjax = {"ajaxurl":"http:\/\/thevancougar.com\/wp-admin\/admin-ajax.php"};
var ftsAjax = {"ajaxurl":"http:\/\/thevancougar.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/feed-them-social/admin/js/admin.js?ver=2.4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"http:\/\/thevancougar.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.2.0'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/feed-them-social/feeds/js/powered-by.js?ver=2.4.6'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/feed-them-social/feeds/js/fts-global.js?ver=2.4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var post_grid_ajax = {"post_grid_ajaxurl":"http:\/\/thevancougar.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/post-grid/assets/frontend/js/scripts.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/post-grid/assets/frontend/js/masonry.pkgd.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/post-grid/assets/frontend/js/owl.carousel.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/post-grid/assets/frontend/js/imagesloaded.pkgd.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='http://thevancougar.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://thevancougar.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://thevancougar.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Putting the gears into motion' href='http://thevancougar.com/2018/07/09/putting-the-gears-into-motion/' />
<link rel='next' title='Pullman’s cruiser makes a trip to campus' href='http://thevancougar.com/2018/08/20/pullmans-cruiser-makes-a-trip-to-campus/' />
<meta name="generator" content="WordPress 4.9.8" />
<link rel="canonical" href="http://thevancougar.com/2018/08/07/new-aswsuv-senators-vote-to-begin-impeachment-process/" />
<link rel='shortlink' href='https://wp.me/p9Jcio-iO' />
<link rel="alternate" type="application/json+oembed" href="http://thevancougar.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthevancougar.com%2F2018%2F08%2F07%2Fnew-aswsuv-senators-vote-to-begin-impeachment-process%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://thevancougar.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthevancougar.com%2F2018%2F08%2F07%2Fnew-aswsuv-senators-vote-to-begin-impeachment-process%2F&#038;format=xml" />
<!-- <meta name="NextGEN" version="2.2.54" /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
				<style type="text/css">
					.site-title a,
			.site-description {
				color: #bfbfbf;
			}
				</style>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="New ASWSUV Senators vote to begin impeachment process" />
<meta property="og:url" content="http://thevancougar.com/2018/08/07/new-aswsuv-senators-vote-to-begin-impeachment-process/" />
<meta property="og:description" content="Follow up coverage of recent Senate meeting A four-fifths vote from the Associated Students of Washington State University Vancouver Senate on Friday, Aug. 3, initiated the impeachment proceedings …" />
<meta property="article:published_time" content="2018-08-07T22:54:40+00:00" />
<meta property="article:modified_time" content="2018-08-08T00:30:02+00:00" />
<meta property="og:site_name" content="The VanCougar" />
<meta property="og:image" content="http://thevancougar.com/wp-content/uploads/2018/08/senate807.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="860" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="New ASWSUV Senators vote to begin impeachment process" />
<meta name="twitter:image" content="http://thevancougar.com/wp-content/uploads/2018/08/senate807.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<style type="text/css">.saboxplugin-wrap {margin-top:0px; margin-bottom:0px; padding: 0px 0px }.saboxplugin-wrap .saboxplugin-authorname {font-size:18px; line-height:25px;}.saboxplugin-wrap .saboxplugin-desc p, .saboxplugin-wrap .saboxplugin-desc {font-size:14px !important; line-height:21px !important;}.saboxplugin-wrap .saboxplugin-web {font-size:14px;}.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa:before {font-size:18px;}.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa {width:36px; height:36px; line-height:36px; }</style><link rel="icon" href="http://thevancougar.com/wp-content/uploads/2017/09/cropped-Cougarhead-1-32x32.png" sizes="32x32" />
<link rel="icon" href="http://thevancougar.com/wp-content/uploads/2017/09/cropped-Cougarhead-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://thevancougar.com/wp-content/uploads/2017/09/cropped-Cougarhead-1-180x180.png" />
<meta name="msapplication-TileImage" content="http://thevancougar.com/wp-content/uploads/2017/09/cropped-Cougarhead-1-270x270.png" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="http://thevancougar.com/?custom-css=7a270f957f" />
		</head>

<body class="post-template-default single single-post postid-1166 single-format-standard full-width-content ">

    <div id="af-preloader">
        <div class="af-loader">
            <div class="loader-circle"></div>
        </div>
    </div>

<div id="page" class="site">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>
            <div class="top-masthead ">
            <div class="container">
                <div class="row">
                                            <div class="col-xs-12 col-sm-12 col-md-8 device-center">
                                
                                                        </div>
                                                        </div>
            </div>
        </div> <!--    Topbar Ends-->
        <header id="masthead" class="site-header">
                <div class="masthead-banner data-bg" data-background="http://thevancougar.com/wp-content/uploads/2018/10/cropped-30292973977_b7731aeafc_o.jpg">
            <div class="container">
                <div class="row">
                    <div class="col-md-12">
                        <div class="site-branding">
                                                            <p class="site-title font-family-1">
                                    <a href="http://thevancougar.com/" rel="home">The VanCougar</a>
                                </p>
                            
                                                    </div>
                    </div>
                </div>
            </div>
        </div>
        <nav id="site-navigation" class="main-navigation">
            <div class="container">
                <div class="row">
                    <div class="col-md-12">
                        <div class="navigation-container">
                                                        <span class="af-search-click icon-search">
                                <i class="fa fa-search"></i>
                            </span>
                            <span class="toggle-menu" aria-controls="primary-menu" aria-expanded="false">
                                <span class="screen-reader-text">Primary Menu</span>
                                 <i class="ham"></i>
                            </span>
                            <div class="menu main-menu"><ul id="primary-menu" class="menu"><li id="menu-item-26" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-26"><a href="http://thevancougar.com/">HOME</a></li>
<li id="menu-item-50" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-50"><a href="http://thevancougar.com/news/">NEWS</a></li>
<li id="menu-item-1324" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1324"><a href="http://thevancougar.com/category/opinion/">OPINION</a></li>
<li id="menu-item-1138" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1138"><a href="http://thevancougar.com/the-staff/">The Staff</a></li>
<li id="menu-item-1139" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1139"><a href="http://thevancougar.com/social-timeline/">Social Timeline</a></li>
<li id="menu-item-1519" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1519"><a href="http://thevancougar.com/category/issuu/">ISSUU</a></li>
<li id="menu-item-153" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-153"><a href="http://thevancougar.com/archive">ARCHIVE</a></li>
</ul></div>                        </div>
                    </div>
                </div>
            </div>
        </nav>
    </header>

    <div id="af-search-wrap">
        <div class="af-search-box table-block">
            <div class="table-block-child v-center text-center">
                <form role="search" method="get" class="search-form" action="http://thevancougar.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>            </div>
        </div>
        <div class="af-search-close af-search-click">
            <span></span>
            <span></span>
        </div>
    </div>

        <div id="content" class="site-content">
    
    <div id="primary" class="content-area">
        <main id="main" class="site-main">

                            <article id="post-1166" class="post-1166 post type-post status-publish format-standard has-post-thumbnail hentry category-student-government">
                    <header class="entry-header">
                    <div class="post-thumbnail full-width-image">
                    <img width="1024" height="688" src="http://thevancougar.com/wp-content/uploads/2018/08/senate807-1024x688.jpg" class="attachment-elegant-magazine-featured size-elegant-magazine-featured wp-post-image" alt="" srcset="http://thevancougar.com/wp-content/uploads/2018/08/senate807-1024x688.jpg 1024w, http://thevancougar.com/wp-content/uploads/2018/08/senate807-300x202.jpg 300w, http://thevancougar.com/wp-content/uploads/2018/08/senate807-768x516.jpg 768w, http://thevancougar.com/wp-content/uploads/2018/08/senate807.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" />                </div>
            
            <div class="header-details-wrapper">
        <div class="entry-header-details">
                            <div class="figure-categories figure-categories-bg">
                                        <span class="cat-links"> <a href="http://thevancougar.com/category/student-government/" rel="category tag">STUDENT GOVERNMENT</a></span>                </div>
                        <h1 class="entry-title">New ASWSUV Senators vote to begin impeachment process</h1>			<h2 style="text-transform: uppercase; font-style: italic; padding-bottom: 10px;">Follow up coverage of recent Senate meeting</h2>                                        <div class="post-item-metadata entry-meta">
                            <span class="item-metadata posts-author">
            <span class="">By</span>
            <a href="http://thevancougar.com/author/cameronkast/">
                Cameron Kast            </a>
        </span>
        <span class="">/</span>
        <span class="item-metadata posts-date">
            August 7, 2018        </span>
                        </div>
                    </div>
    </div>
</header><!-- .entry-header -->                    <div class="entry-content-wrap">
                                        <div class="entry-content">
                <h2>Follow up coverage of recent Senate meeting</h2>
<p>A four-fifths vote from the Associated Students of Washington State University Vancouver Senate on Friday, Aug. 3, initiated the impeachment proceedings of current Senate Pro-Tempore, Taryn Loun.</p>
<p>ASWSUV Senator Gregory Olson asked shortly after the start of the meeting to move the discussion and vote to a private session, where students and staff would not be in the room. However, Interim Vice President Travis Toth said that due to <a href="https://app.leg.wa.gov/rcw/default.aspx?cite=42.30.200">Washington Administrative Code</a>, the meeting would remain public and would not be moved to a private session.</p>
<p>“I don’t think anyone should be embarrassed,” Olson said when asked about his request to move to a private session. All ASWSUV Senate meetings are open to the public, along with meeting agendas and meeting minutes. Additionally, each meeting agenda allots a time slot for public comment where meeting attendees have the opportunity to ask questions or comment on the discussions held at the Senate table.</p>
<p>During the public meeting students and Senators had the chance to voice their opinions with regards to continuing the impeachment process. Senator Loun said in her personal statement at the meeting that ASWSUV has problems with checks and balances. Loun also said that she would be willing to step down from her position of Senate Pro-Tempore if absolutely necessary.</p>
<p>Friday’s vote was not the vote to impeach Senator Loun, however it was the vote needed to start the impeachment process. The date and time of the next Senate meeting is still to be determined.</p>
<p><a href="https://business.facebook.com/TheVanCougar/videos/1945913838773549/">To learn more about this story, view The VanCougar&#8217;s livestream of last week&#8217;s meeting of the ASWSUV Senate</a></p>
<div class="saboxplugin-wrap"><div class="saboxplugin-gravatar"><img src="http://thevancougar.com/wp-content/uploads/2018/09/CameronKast_7-10-18_ARW7.jpg"></div><div class="saboxplugin-authorname"><a href="http://thevancougar.com/author/cameronkast/" class="vcard author"><span class="fn">Cameron Kast</span></a></div><div class="saboxplugin-desc"><div></div></div><div class="clearfix"></div><div class="saboxplugin-socials sabox-colored"></div></div>                                    <div class="post-item-metadata entry-meta">
                                            </div>
                                            </div><!-- .entry-content -->
            <footer class="entry-footer">
                            </footer>


    

<div class="em-reated-posts clearfix">
            <h2 class="related-title">
            You may also like        </h2>
        <ul>
                    <li>
                <h3 class="article-title"><a href="http://thevancougar.com/2018/10/02/qa-new-aswsuv-president-vince-chavez-and-vice-president-holly-ta/" rel="bookmark">Q&#038;A: New ASWSUV President Vince Chavez and Vice President Holly Ta</a>
            </h3>                <div class="grid-item-metadata">
                            <span class="item-metadata posts-author">
            <span class="">By</span>
            <a href="http://thevancougar.com/author/cameronkast/">
                Cameron Kast            </a>
        </span>
        <span class="">/</span>
        <span class="item-metadata posts-date">
            October 2, 2018        </span>
                        </div>
            </li>
                    <li>
                <h3 class="article-title"><a href="http://thevancougar.com/2018/09/18/student-government-holds-special-election-for-president-and-vice-president/" rel="bookmark">Student government holds special election for president and vice president</a>
            </h3>                <div class="grid-item-metadata">
                            <span class="item-metadata posts-author">
            <span class="">By</span>
            <a href="http://thevancougar.com/author/cameronkast/">
                Cameron Kast            </a>
        </span>
        <span class="">/</span>
        <span class="item-metadata posts-date">
            September 18, 2018        </span>
                        </div>
            </li>
                    <li>
                <h3 class="article-title"><a href="http://thevancougar.com/2018/09/04/recently-appointed-aswsuv-senator-earns-herself-a-seat-at-the-table/" rel="bookmark">Recently appointed ASWSUV senator earns herself a seat at the table</a>
            </h3>                <div class="grid-item-metadata">
                            <span class="item-metadata posts-author">
            <span class="">By</span>
            <a href="http://thevancougar.com/author/aduffield/">
                Alexander Duffield            </a>
        </span>
        <span class="">/</span>
        <span class="item-metadata posts-date">
            September 4, 2018        </span>
                        </div>
            </li>
                    <li>
                <h3 class="article-title"><a href="http://thevancougar.com/2018/08/31/taryn-loun-to-remain-senate-pro-tempore/" rel="bookmark">Senator Taryn Loun to remain in office</a>
            </h3>                <div class="grid-item-metadata">
                            <span class="item-metadata posts-author">
            <span class="">By</span>
            <a href="http://thevancougar.com/author/cameronkast/">
                Cameron Kast            </a>
        </span>
        <span class="">/</span>
        <span class="item-metadata posts-date">
            August 31, 2018        </span>
                        </div>
            </li>
                    <li>
                <h3 class="article-title"><a href="http://thevancougar.com/2018/07/09/putting-the-gears-into-motion/" rel="bookmark">Putting the gears into motion</a>
            </h3>                <div class="grid-item-metadata">
                            <span class="item-metadata posts-author">
            <span class="">By</span>
            <a href="http://thevancougar.com/author/cameronkast/">
                Cameron Kast            </a>
        </span>
        <span class="">/</span>
        <span class="item-metadata posts-date">
            July 9, 2018        </span>
                        </div>
            </li>
            </ul>
</div>



	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://thevancougar.com/2018/07/09/putting-the-gears-into-motion/" rel="prev">Putting the gears into motion</a></div><div class="nav-next"><a href="http://thevancougar.com/2018/08/20/pullmans-cruiser-makes-a-trip-to-campus/" rel="next">Pullman’s cruiser makes a trip to campus</a></div></div>
	</nav>
<div id="comments" class="comments-area">

			<h2 class="comments-title">
			1 thought on &ldquo;<span>New ASWSUV Senators vote to begin impeachment process</span>&rdquo;		</h2><!-- .comments-title -->

		
		<ol class="comment-list">
					<li id="comment-168" class="comment even thread-even depth-1">
			<article id="div-comment-168" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='http://2.gravatar.com/avatar/81732bd17c98f158146daa544d09cdf1?s=32&#038;d=identicon&#038;r=g' srcset='http://2.gravatar.com/avatar/81732bd17c98f158146daa544d09cdf1?s=64&#038;d=identicon&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' />						<b class="fn">Mitchell James Carey</b> <span class="says">says:</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="http://thevancougar.com/2018/08/07/new-aswsuv-senators-vote-to-begin-impeachment-process/#comment-168">
							<time datetime="2018-08-09T11:17:31+00:00">
								August 9, 2018 at 11:17 am							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>What is the reasoning for her impeachment?</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
</li><!-- #comment-## -->
		</ol><!-- .comment-list -->

					<p class="no-comments">Comments are closed.</p>
		
</div><!-- #comments -->
                    </div>
                </article>
            
        </main><!-- #main -->
    </div><!-- #primary -->

<!--
<aside id="secondary" class="widget-area">
    <div class="theiaStickySidebar">
	        </div>
</aside><!-- #secondary -->


</div>



<footer class="site-footer">
        <div class="primary-footer">
        <div class="container">
            <div class="row">
                <div class="col-sm-12">
                    <div class="row">
                                                            <div class="primary-footer-area footer-first-widgets-section col-md-4 col-sm-12">
                                    <section class="widget-area">
                                            <div id="media_image-5" class="widget elegant-widget widget_media_image"><img width="300" height="297" src="http://thevancougar.com/wp-content/uploads/2017/09/Cougarhead-1-300x297.png" class="image wp-image-221  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="http://thevancougar.com/wp-content/uploads/2017/09/Cougarhead-1-300x297.png 300w, http://thevancougar.com/wp-content/uploads/2017/09/Cougarhead-1-150x150.png 150w, http://thevancougar.com/wp-content/uploads/2017/09/Cougarhead-1-768x761.png 768w, http://thevancougar.com/wp-content/uploads/2017/09/Cougarhead-1-1024x1015.png 1024w, http://thevancougar.com/wp-content/uploads/2017/09/Cougarhead-1.png 1559w" sizes="(max-width: 300px) 100vw, 300px" /></div>                                    </section>
                                </div>
                            
                                                    <div class="primary-footer-area footer-second-widgets-section col-md-4 col-sm-12">
                                <section class="widget-area">
                                    <div id="nav_menu-2" class="widget elegant-widget widget_nav_menu"><h2 class="widget-title widget-title-1">site map</h2><div class="menu-categories-footer-container"><ul id="menu-categories-footer" class="menu"><li id="menu-item-264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264"><a href="http://thevancougar.com/archive">ARCHIVE</a></li>
<li id="menu-item-262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-262"><a href="http://thevancougar.com/contact/">CONTACT US</a></li>
<li id="menu-item-267" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-267"><a href="http://thevancougar.com/category/corrections/">CORRECTIONS</a></li>
<li id="menu-item-255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-255"><a href="http://thevancougar.com/partners/">PARTNERS</a></li>
<li id="menu-item-250" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-250"><a href="http://thevancougar.com/terms-of-services/">TERMS OF SERVICES</a></li>
<li id="menu-item-251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-251"><a href="http://thevancougar.com/vancougar-policies/">VANCOUGAR POLICIES</a></li>
<li id="menu-item-322" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-322"><a href="http://thevancougar.com/category/issuu/">ISSUU</a></li>
</ul></div></div>                                </section>
                            </div>
                        
                                                    <div class="primary-footer-area footer-third-widgets-section col-md-4 col-sm-12">
                                <section class="widget-area">
                                    <div id="recent-comments-4" class="widget elegant-widget widget_recent_comments"><h2 class="widget-title widget-title-1">Recent Comments</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Doug McBride</span> on <a href="http://thevancougar.com/2018/10/30/high-anxieties-low-turnout/#comment-194">HIGH ANXIETIES | low turnout</a></li><li class="recentcomments"><span class="comment-author-link">Doug</span> on <a href="http://thevancougar.com/2018/10/19/patriot-prayer-group-to-visit-wsu-vancouver-continued-coverage/#comment-191">Patriot Prayer group to visit WSU Vancouver: Continued coverage</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://vcea.wsu.edu/faculty-staff/2018/09/18/voiland-college-this-week-20/' rel='external nofollow' class='url'>Voiland College This Week | Voiland College Faculty and Staff | Washington State University</a></span> on <a href="http://thevancougar.com/2018/09/04/for-the-aerospace-club-the-sky-is-the-limit/#comment-182">For the Aerospace club, the sky is the limit</a></li><li class="recentcomments"><span class="comment-author-link">Mitchell James Carey</span> on <a href="http://thevancougar.com/2018/08/07/new-aswsuv-senators-vote-to-begin-impeachment-process/#comment-168">New ASWSUV Senators vote to begin impeachment process</a></li><li class="recentcomments"><span class="comment-author-link">admin</span> on <a href="http://thevancougar.com/2018/03/05/engineering-a-community-for-women/#comment-167">Engineering a community for women</a></li></ul></div>                                </section>
                            </div>
                                            </div>
                </div>
            </div>
        </div>
    </div>
        <div class="footer-logo-branding">
        <div class="container">
            <div class="row">
                <div class="col-sm-12">
                    <div class="footer-logo">
                        <div class="site-branding">
                                                        <h3 class="site-title font-family-1">
                                <a href="http://thevancougar.com/" rel="home">The VanCougar</a>
                            </h3>
                                                    </div>
                    </div>
                </div>
            </div>
        </div>
    </div>
        <div class="secondary-footer">
        <div class="container">
            <div class="row">
                                                    <div class="col-sm-12">
                        <div class="footer-social-wrapper">
                            <div class="social-navigation"><ul id="social-menu" class="menu"><li id="menu-item-107" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-107"><a href="https://www.facebook.com/TheVanCougar/?ref=aymt_homepage_panel"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-155" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-155"><a href="https://twitter.com/thevancougar"><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-111" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111"><a href="https://www.instagram.com/thevancougar/?hl=en"><span class="screen-reader-text">Instagram</span></a></li>
</ul></div>                        </div>
                    </div>
                            </div>
        </div>
    </div>
        <div class="site-info">
        <div class="container">
            <div class="row">
                <div class="col-sm-12">
                                                                Copyright &copy; All rights reserved.                                        <span class="sep"> | </span>
                    Theme: <a href="https://afthemes.com/elegant-magazine">Elegant Magazine</a> by <a href="https://afthemes.com/">AF themes</a>.                </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>
<!-- ngg_resource_manager_marker --><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/thevancougar.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.1'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201846'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2018Novaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/themes/elegant-magazine/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/themes/elegant-magazine/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/themes/elegant-magazine/assets/slick/js/slick.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/themes/elegant-magazine/assets/bootstrap/js/bootstrap.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/themes/elegant-magazine/assets/sidr/js/jquery.sidr.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/themes/elegant-magazine/assets/jquery-match-height/jquery.matchHeight.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/themes/elegant-magazine/lib/marquee/jquery.marquee.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/themes/elegant-magazine/lib/theiaStickySidebar/theia-sticky-sidebar.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-content/themes/elegant-magazine/assets/script.js?ver=4.9.8'></script>
<script type='text/javascript' src='http://thevancougar.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
	<div style="display:none">
	<div class="grofile-hash-map-81732bd17c98f158146daa544d09cdf1">
	</div>
	</div>
<script type='text/javascript' src='https://stats.wp.com/e-201846.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.0',blog:'143759052',post:'1166',tz:'-7',srv:'thevancougar.com'} ]);
	_stq.push([ 'clickTrackerInit', '143759052', '1166' ]);
</script>

</body>
</html>

<!--Generated by Endurance Page Cache-->